]> git.wincent.com - wikitext.git/commitdiff
Prepare 4.6 release 4.6
authorGreg Hurrell <greg@hurrell.net>
Tue, 25 Dec 2018 12:30:30 +0000 (13:30 +0100)
committerGreg Hurrell <greg@hurrell.net>
Tue, 25 Dec 2018 12:30:30 +0000 (13:30 +0100)
For compatibility with the yearly Christmas release of Ruby (this time
v2.6). Note I dropped the (unused anyway) ZenTest dependency, which
otherwise complains:

    ZenTest-4.11.0 requires rubygems version < 3.0, which is
    incompatible with the current version, 3.0.1

Updated local Ruby install first with:

    ruby-install ruby 2.6.0

For some reason, chruby doesn't pick it up (probably because I didn't
start a new shell), so I:

    export PATH=~/.rubies/ruby-2.6.0/bin:$PATH

.ruby-version
Gemfile.lock
doc/RELEASE-NOTES
ext/wikitext/extconf.rb
lib/wikitext/version.rb
wikitext.gemspec

index 437459cd94c9fa59d82c61c0bc8aa36e293b735e..e70b4523ae7ffe8aa3cac8ecd1b093fba5a98737 100644 (file)
@@ -1 +1 @@
-2.5.0
+2.6.0
index 69adf0936f69fb2b11d4097e042c4a8655cbfea5..267cee5cfc4be46b508b8ba29df60fb360360f50 100644 (file)
@@ -1,12 +1,11 @@
 PATH
   remote: .
   specs:
-    wikitext (4.5)
+    wikitext (4.6)
 
 GEM
   remote: https://rubygems.org/
   specs:
-    ZenTest (4.11.0)
     diff-lcs (1.2.5)
     rake (10.4.2)
     rspec (2.99.0)
@@ -25,7 +24,6 @@ PLATFORMS
   ruby
 
 DEPENDENCIES
-  ZenTest (~> 4.9)
   rake (~> 10.0)
   rspec (~> 2.13)
   thor (~> 0.17.0)
@@ -34,4 +32,4 @@ DEPENDENCIES
   yard (~> 0.9.12)
 
 BUNDLED WITH
-   1.16.1
+   1.17.2
index 5eac6e07f63f07f0001e833a5a4850e6366d6f97..b3f976d93fe67ed8887e7433963dbd7751552790 100644 (file)
@@ -6,6 +6,10 @@ require any user or developer action are generally not included
 in these release notes. For a full listing of all changes see
 the source code repository at: http://git.wincent.com.
 
+= Changes in 4.6
+
+* add official support for Ruby 2.6.x
+
 = Changes in 4.5
 
 * add official support for Ruby 2.5.x
index 99a69b1e0086a90ebc7353eb97669747912941c5..1c8808665f0abcea9c48a348e60194e1b15507ef 100644 (file)
@@ -28,7 +28,7 @@ def missing item
   exit 1
 end
 
-if RUBY_VERSION !~ /\A2\.[0-5](\.|$)/
+if RUBY_VERSION !~ /\A2\.[0-6](\.|$)/
   raise "unsupported Ruby version: #{RUBY_VERSION}"
 end
 
index 81e13b495016d8391bc9d0614b1099d74f0e295b..606f91e6810a5ff9e574c062630f6fd055b39966 100644 (file)
@@ -22,5 +22,5 @@
 # POSSIBILITY OF SUCH DAMAGE.
 
 module Wikitext
-  VERSION = '4.5'
+  VERSION = '4.6'
 end # module Wikitext
index de1f0b27665cfb6ef45b931124bf1bd5b7692bf7..b1918a61008a5ba96c7ad87749c33c66a7b602ca 100644 (file)
@@ -53,5 +53,4 @@ Gem::Specification.new do |s|
   s.add_development_dependency 'thor', '~> 0.17.0'
   s.add_development_dependency 'yard', '~> 0.9.12'
   s.add_development_dependency 'wopen3', '~> 0.3'
-  s.add_development_dependency 'ZenTest', '~> 4.9'
 end