]> git.wincent.com - wikitext.git/commitdiff
Drop support for Rails 3.0.x
authorWincent Colaiuta <win@wincent.com>
Sat, 28 May 2011 06:07:12 +0000 (23:07 -0700)
committerWincent Colaiuta <win@wincent.com>
Sat, 28 May 2011 06:07:12 +0000 (23:07 -0700)
In the interests of moving forward, older versions of Rails will
continue to be supported with the last Wikitext release (2.1.1, 2.1.x),
but the current version will only support Rails 3.1.0 and above.

Signed-off-by: Wincent Colaiuta <win@wincent.com>
spec/rails_spec.rb

index e11e7465c9e1ed47cf690dac04ed66eeabbe851a..81835b0bb2d91e7a14be6d01f3530be6ea213ec7 100644 (file)
@@ -210,13 +210,7 @@ TEST
 end # module RailsSpecs
 
 # different versions of Rails require different versions of Arel
-{ '3.0.1' => '1.0.1',
-  '3.0.2' => '2.0.3',
-  '3.0.3' => '2.0.3',
-  '3.0.4' => '2.0.3',
-  '3.0.5' => '2.0.3',
-  '3.0.6' => '2.0.3',
-  '3.0.7' => '2.0.3' }.each do |rails_version, arel_version|
+{ '3.1.0' => '2.1.1' }.each do |rails_version, arel_version|
   describe "Template handler in Rails #{rails_version}" do
     include RailsSpecs