]> git.wincent.com - wikitext.git/commitdiff
Update to RSpec 2.2 for faster spec runs
authorWincent Colaiuta <win@wincent.com>
Wed, 1 Dec 2010 14:31:02 +0000 (15:31 +0100)
committerWincent Colaiuta <win@wincent.com>
Wed, 1 Dec 2010 14:31:02 +0000 (15:31 +0100)
Signed-off-by: Wincent Colaiuta <win@wincent.com>
12 files changed:
Gemfile.lock
bin/autospec [new file with mode: 0755]
bin/htmldiff
bin/ldiff
bin/rake
bin/rake2thor
bin/rspec
bin/thor
bin/yard
bin/yardoc
bin/yri
wikitext.gemspec

index 376b0511afaa77397fa12ac27c65cca7c50e1f58..54a21e8d04809074eba684ea56b3eea98dba6a3f 100644 (file)
@@ -1,23 +1,21 @@
 PATH
   remote: .
   specs:
-    wikitext (2.1.0.99)
+    wikitext (2.1.1.99)
 
 GEM
   remote: http://rubygems.org/
   specs:
     diff-lcs (1.1.2)
     rake (0.8.7)
-    rspec (2.0.0)
-      rspec-core (= 2.0.0)
-      rspec-expectations (= 2.0.0)
-      rspec-mocks (= 2.0.0)
-    rspec-core (2.0.0)
-    rspec-expectations (2.0.0)
-      diff-lcs (>= 1.1.2)
-    rspec-mocks (2.0.0)
-      rspec-core (= 2.0.0)
-      rspec-expectations (= 2.0.0)
+    rspec (2.2.0)
+      rspec-core (~> 2.2)
+      rspec-expectations (~> 2.2)
+      rspec-mocks (~> 2.2)
+    rspec-core (2.2.1)
+    rspec-expectations (2.2.0)
+      diff-lcs (~> 1.1.2)
+    rspec-mocks (2.2.0)
     thor (0.14.3)
     wopen3 (0.3)
     yard (0.6.1)
@@ -27,7 +25,7 @@ PLATFORMS
 
 DEPENDENCIES
   rake
-  rspec (~> 2.0.0)
+  rspec (~> 2.0)
   thor
   wikitext!
   wopen3
diff --git a/bin/autospec b/bin/autospec
new file mode 100755 (executable)
index 0000000..64dcb9c
--- /dev/null
@@ -0,0 +1,16 @@
+#!/usr/bin/env ruby
+#
+# This file was generated by Bundler.
+#
+# The application 'autospec' is installed as part of a gem, and
+# this file is here to facilitate running it.
+#
+
+require 'pathname'
+ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile",
+  Pathname.new(__FILE__).realpath)
+
+require 'rubygems'
+require 'bundler/setup'
+
+load Gem.bin_path('rspec-core', 'autospec')
index 80266d3265c8023e30d6f0ca7d6fa66d2475655d..c70e238dc2d81ab8ecc70537203db00db723e4e4 100755 (executable)
@@ -6,7 +6,9 @@
 # this file is here to facilitate running it.
 #
 
-ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile", __FILE__)
+require 'pathname'
+ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile",
+  Pathname.new(__FILE__).realpath)
 
 require 'rubygems'
 require 'bundler/setup'
index 55ef3aae6447976aec4c34eb8e45908e7ffa8995..8e3524a92e366c5fcfba0c83b7b3eca0b94fafdb 100755 (executable)
--- a/bin/ldiff
+++ b/bin/ldiff
@@ -6,7 +6,9 @@
 # this file is here to facilitate running it.
 #
 
-ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile", __FILE__)
+require 'pathname'
+ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile",
+  Pathname.new(__FILE__).realpath)
 
 require 'rubygems'
 require 'bundler/setup'
index 9f826fd215da51461c8d4a0ceba7b299c9b889bd..26c7a2d5b5f18e50c555558e19ed6050ab461628 100755 (executable)
--- a/bin/rake
+++ b/bin/rake
@@ -6,7 +6,9 @@
 # this file is here to facilitate running it.
 #
 
-ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile", __FILE__)
+require 'pathname'
+ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile",
+  Pathname.new(__FILE__).realpath)
 
 require 'rubygems'
 require 'bundler/setup'
index 323472746f297b938e4835fc21e539e488e2930c..b0b6ec9b869378330c3c20a2f92abb5fe89c7239 100755 (executable)
@@ -6,7 +6,9 @@
 # this file is here to facilitate running it.
 #
 
-ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile", __FILE__)
+require 'pathname'
+ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile",
+  Pathname.new(__FILE__).realpath)
 
 require 'rubygems'
 require 'bundler/setup'
index d7f4c7b7499a3b2272adb2bda939dfbe97761fa5..0c86b5c6fa177ab2b58ee7146e19d0d26506487d 100755 (executable)
--- a/bin/rspec
+++ b/bin/rspec
@@ -6,7 +6,9 @@
 # this file is here to facilitate running it.
 #
 
-ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile", __FILE__)
+require 'pathname'
+ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile",
+  Pathname.new(__FILE__).realpath)
 
 require 'rubygems'
 require 'bundler/setup'
index 2f831c17d5d6096e2a790bf2de7131e112a156a2..8421e001eac7fd15bc92dc8d30c1390139252833 100755 (executable)
--- a/bin/thor
+++ b/bin/thor
@@ -6,7 +6,9 @@
 # this file is here to facilitate running it.
 #
 
-ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile", __FILE__)
+require 'pathname'
+ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile",
+  Pathname.new(__FILE__).realpath)
 
 require 'rubygems'
 require 'bundler/setup'
index efa04b42fd65f57ca36043fc7b64fff2cbc78214..bd489a82952280a12386a77b5262fe44b1d71d2a 100755 (executable)
--- a/bin/yard
+++ b/bin/yard
@@ -6,7 +6,9 @@
 # this file is here to facilitate running it.
 #
 
-ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile", __FILE__)
+require 'pathname'
+ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile",
+  Pathname.new(__FILE__).realpath)
 
 require 'rubygems'
 require 'bundler/setup'
index 2aa1856c6c14f8db9e57c421e1e775cdc5cb2291..43eff6b0a5d1c934be6897296e1dae00be71b9a7 100755 (executable)
@@ -6,7 +6,9 @@
 # this file is here to facilitate running it.
 #
 
-ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile", __FILE__)
+require 'pathname'
+ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile",
+  Pathname.new(__FILE__).realpath)
 
 require 'rubygems'
 require 'bundler/setup'
diff --git a/bin/yri b/bin/yri
index c646c9d1ff58a40a3816083860ecfb6483f45d2d..05f2461171ce5c1d8340a1dcebe3118087a9b1ac 100755 (executable)
--- a/bin/yri
+++ b/bin/yri
@@ -6,7 +6,9 @@
 # this file is here to facilitate running it.
 #
 
-ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile", __FILE__)
+require 'pathname'
+ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile",
+  Pathname.new(__FILE__).realpath)
 
 require 'rubygems'
 require 'bundler/setup'
index c37f3dc917a6fff0f80d61e4d42fa7f731cd8f5f..40a9796c4117a2ef4ee4f297a772557e2a3d10c7 100644 (file)
@@ -52,7 +52,7 @@ Gem::Specification.new do |s|
     end
   end
   s.add_development_dependency 'rake'
-  s.add_development_dependency 'rspec', '~> 2.0.0'
+  s.add_development_dependency 'rspec', '~> 2.0'
   s.add_development_dependency 'thor'
   s.add_development_dependency 'yard', '>= 0.5.8'
   s.add_development_dependency 'wopen3'