]> git.wincent.com - wikitext.git/commit
Tweak extension build for Leopard compatibility
authorWincent Colaiuta <win@wincent.com>
Tue, 30 Oct 2007 01:48:05 +0000 (02:48 +0100)
committerWincent Colaiuta <win@wincent.com>
Tue, 30 Oct 2007 01:48:05 +0000 (02:48 +0100)
commit7a51010287ac895f1a7f1c3717a62a0194856ce6
treeabb38545cae71f71faeba68c59c321fd43aedbe0
parentb5c0548b7b62bd325ae743bd6cd9f5c063962cc4
Tweak extension build for Leopard compatibility

These tweaks fix the build breakage under Leopard caused by the fact that
the ANTLR runtime is non-Universal and Ruby is Universal. We set the
ARCHFLAGS environment variable to force a non-Universal extension to be
built.

In the future may actually produce a Universal version of the runtime, at
which point will remove this somewhat kludgy hack.

Signed-off-by: Wincent Colaiuta <win@wincent.com>
Rakefile
ext/extconf.rb