]> git.wincent.com - wikitext.git/commit
Don't test against Rails 2 versions
authorWincent Colaiuta <win@wincent.com>
Sun, 15 May 2011 04:15:22 +0000 (21:15 -0700)
committerWincent Colaiuta <win@wincent.com>
Sun, 15 May 2011 04:15:22 +0000 (21:15 -0700)
commit791f464c6db485ec3309b2dd3e6e8a378363f6f0
tree579b0489d94362b13b3fd5ee6d88652ed9886759
parentd38b5fa9c4f47176410b64decdfcc0e51792c291
Don't test against Rails 2 versions

Testing against so many versions of Rails is proving to be a
maintenance nightmare, so we're going to change tack: I'll continue to
support the current 2.x series of the Wikitext gem, and it will work
perfectly with Rails 2.x.

I'll also be supporting a new 3.x series of the gem, which will support
only Rails 3.x. It is relatively easy to support multiple versions of
the gem, each tailored for a particular version of Rails, compared with
trying to get a single version fo the gem to support all versions (see
the hoops that Haml jumps through to do this).

Additionally, testing against so many versions is complicated even more
when Bundler is added to the equation. From here on I'll be
concentrating on making the Rails specs Bundler-aware, but evidently
only in the 3.x branch, and only against Rails 3.x.

Signed-off-by: Wincent Colaiuta <win@wincent.com>
spec/rails_spec.rb