]> git.wincent.com - wikitext.git/commit
Prepare 4.6 release 4.6
authorGreg Hurrell <greg@hurrell.net>
Tue, 25 Dec 2018 12:30:30 +0000 (13:30 +0100)
committerGreg Hurrell <greg@hurrell.net>
Tue, 25 Dec 2018 12:30:30 +0000 (13:30 +0100)
commit6c14d4dd2e08d780d6c57d64fc73eefc09c06f62
tree3b3f8debb832b8ef2fef075e4405ff784de6d5b1
parente2ec462113394dd0ce775efa4b3231e5cf86dc3c
Prepare 4.6 release

For compatibility with the yearly Christmas release of Ruby (this time
v2.6). Note I dropped the (unused anyway) ZenTest dependency, which
otherwise complains:

    ZenTest-4.11.0 requires rubygems version < 3.0, which is
    incompatible with the current version, 3.0.1

Updated local Ruby install first with:

    ruby-install ruby 2.6.0

For some reason, chruby doesn't pick it up (probably because I didn't
start a new shell), so I:

    export PATH=~/.rubies/ruby-2.6.0/bin:$PATH
.ruby-version
Gemfile.lock
doc/RELEASE-NOTES
ext/wikitext/extconf.rb
lib/wikitext/version.rb
wikitext.gemspec