]> git.wincent.com - hextrapolate.git/blobdiff - package.json
babel → babel-cli
[hextrapolate.git] / package.json
index ae91d9d50f3430b42e98e6f6f064b1a7de2b65b6..78009a5e40b57ebf74bfa034d5afac820280f14c 100644 (file)
@@ -1,47 +1,49 @@
 {
-  "name": "react-hot-boilerplate",
-  "version": "1.0.0",
-  "description": "Boilerplate for ReactJS project with hot code reloading",
+  "name": "hextrapolate",
+  "version": "0.0.1",
+  "description": "Number base conversion tool",
+  "private": true,
   "scripts": {
     "lint": "eslint src",
-    "start": "node server.js",
+    "start": "gulp webpack-dev-server",
     "test": "mocha --opts mocha/mocha.opts 'src/**/__mocks__/*.js' 'src/**/__tests__/*-test.js'"
   },
   "repository": {
     "type": "git",
-    "url": "https://github.com/gaearon/react-hot-boilerplate.git"
+    "url": "https://github.com/wincent/hextrapolate.git"
   },
   "keywords": [
-    "react",
-    "reactjs",
-    "boilerplate",
-    "hot",
-    "reload",
-    "hmr",
-    "live",
-    "edit",
-    "webpack"
+    "react"
   ],
-  "author": "Dan Abramov <dan.abramov@me.com> (http://github.com/gaearon)",
+  "author": "Greg Hurrell <greg@hurrell.net> (http://github.com/wincent)",
   "license": "MIT",
   "bugs": {
-    "url": "https://github.com/gaearon/react-hot-boilerplate/issues"
+    "url": "https://github.com/wincent/hextrapolate/issues"
   },
-  "homepage": "https://github.com/gaearon/react-hot-boilerplate",
+  "homepage": "https://github.com/wincent/hextrapolate",
   "devDependencies": {
-    "babel": "^5.8.19",
-    "babel-core": "^5.4.7",
-    "babel-eslint": "^3.1.9",
-    "babel-loader": "^5.1.2",
-    "eslint-plugin-react": "^2.3.0",
+    "babel-cli": "^6.24.1",
+    "babel-core": "^6.24.1",
+    "babel-eslint": "^7.2.3",
+    "babel-loader": "^7.0.0",
+    "css-loader": "^0.28.4",
+    "eslint-plugin-react": "^7.0.1",
     "expect": "^1.8.0",
-    "mocha": "^2.2.5",
+    "gulp": "^3.9.0",
+    "gulp-eslint": "^3.0.1",
+    "gulp-flowtype": "^1.0.0",
+    "gulp-spawn-mocha": "^3.3.0",
+    "gulp-util": "^3.0.6",
+    "mocha": "^3.4.2",
     "react-hot-loader": "^1.2.7",
-    "sinon": "^1.15.4",
-    "webpack": "^1.9.6",
-    "webpack-dev-server": "^1.8.2"
+    "sinon": "^2.3.2",
+    "style-loader": "^0.18.1",
+    "webpack": "^2.6.1",
+    "webpack-dev-server": "^2.4.5"
   },
   "dependencies": {
-    "react": "^0.13.0"
+    "classnames": "^2.1.3",
+    "react": "^15.5.4",
+    "simple-debounce": "0.0.3"
   }
 }